Umlaute in der Datenbank von latin1 nach UTF8 korrigieren

Lange habe ich das Problem mit den Umlauten in meinem Blog vor mich hergeschoben, aber heute habe ich endlich mal die Zeit genutzt und das Problem beseitigt. Schon vor einiger Zeit habe ich Dank WordPress von latin1 auf utf8 umstellen ein Lösung des Problems gefunden. Ich weiß gar nicht mehr so genau wie das eigentlich bei mir passiert ist. Entweder als ich von 1blu zu 1&1 gewechselt habe oder als ich ein neues Image auf dem 1&1 vServer installiert habe. Na jedenfalls hatte ich das Problem bis eben, dass die Umlaute in bestimmten, hauptsächliche ältere Beiträge, nicht korrekt („ĂĽ“ statt „ü“, „ö“ tatt „ö“, etc.) angezeigt wurden. Nun habe ich das Tool „DSB’s Umlaut Korrektur (DUK)“ des MySQLDumper-Entwicklers ausprobiert und es hat geklappt.
Das Programm ist eigentlich ganz einfach gestrickt: Vorher am besten ein Backup der Datenbank machen. Schließlich kann immer etwas schief gehen! Die ZIP-Datei runterladen und entpacken. In die mitgelieferte PHP-Datei „dsdb_wrapper.php“ noch die Zugangsdaten (Server, DB-Name, Passwort) zur Datenbank eintragen und diese dann per FTP auf den Server laden. Anschließend muss man nur noch die mitgelieferte EXE-Datei „duk.exe“ starten und dort den Pfad zur PHP-Datei „dsdb_wrapper.php“ auf dem Webserver eintragen. Jetzt ist man eigentlich nur noch 4 Klicks vom Erfolg entfernt. Den ersten Klick macht man auf „Verbinden“. Bei erfolgreicher Verbindung sollten unten schon die Tabellen der DB angezeigt werden. Anschließend klickt man auf „Spaltenstruktur analysieren“. Danach auf „Umlaute prüfen“ und dann auf „Umlaute korrigieren“. Nun werden alle Umlaute automatisch korrigiert. Als Abschluss würde ich empfehlen die PHP-Datei „dsdb_wrapper.php“ vom Webserver nach getaner Arbeit wieder zu entfernen. Sicher ist sicher ;)

Weitere Informationen zum Thema: Workshop gegen das Chaos | Upgrade erfolgreich, Umlaute tot

Websenat reloaded

Nachdem mich mein alter Hoster 1blu sitzen gelassen hat und mein Blog fast 14 Tage nicht erreichbar war, habe ich nun zu 1&1 gewechselt. Dort verichtet auch wieder ein vServer sein Dienst. Bis jetzt sieht es ganz gut aus. Leider war der Umzug eher unfreiwillig, deswegen gibt es nun auch ein anderes Design (WordPress Theme von SoSuechtig.de) und noch einige Änderungen im Hintergrund (an PlugIns und Datenbank). Aber nun ist erstmal Schluss für heute ;)

1blu vServer Probleme

Also, diese Woche ist das noch schlimmer als sonst. Ich musste meinen vServer bei 1blu mindestens 8 Mal neustarten, damit ich diesen wieder erreichen konnte. Wenn sich das die kommende Woche weiter so entwickelt, dann muss ich mich mal nach einem neuen Provider umsehen. 1blu scheint auch nicht auf meine Support-Anfragen zu antworten. Laut Autoresponder anworten die generell erst nach 24-48 Stunden. Das hatte mir auch schon mal ein Support-Mitarbeiter von der Hotline mitgeteilt.
Interessant finde ich aber auch deren FAQ. Besonders diesen Beitrag „Wie kann ich die Erreichbarkeit meines 1blu-vServers / 1blu-DedicatedServers auf einem konstanten Level halten?“ In diesem Beitrag rät 1blu ihren Kunden einen cron-job auf dem vServer zu erstellen, wodurch den vServer dann zu einer bestimmten Uhrzeit neugestartet wird. Das soll eine Lösung sein? Es kann doch nicht sein das man seinen vServer immer neustarten muss, damit dieser wieder ein paar Stunden erreichbar ist. Also unter einer Lösung verstehe ich etwas anderes. Vielleicht kann mir jemand einen neuen Provider empfehlen.

1blu war/ist schuld …

am gestrigen Serverausfall. Mein Server war von gestern 05:00 Uhr bis ca. 21:00 Uhr nicht erreichbar. Für diesen Ausfall möchte ich mich bei Euch entschuldigen. Ein Kollege und ich haben mittlerweile so viel Erfahrung mit 1blu machen dürfen, ich glaube ich spendiere meinem Blog eine separate Kategorie zu dem Thema :) Vielleicht geht es Euch ähnlich.